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I. [bookmark: _Toc85461315]Introduction to Excel Worksheets
[bookmark: _Toc82517887][bookmark: _Toc82518903][bookmark: _Toc85461316][image: ]
A. [bookmark: _Toc85461317]Interesting Facts about Excel
1. How many columns are in an Excel Worksheet?          16,384
2. How many rows are in an Excel Worksheet?           1,048,576
3. How many cells are in an Excel Worksheet?  17,179,869,184
B. [bookmark: _Toc85461318]An Excel workbook can hold any number of worksheets and each worksheet is made up of more than 17 billion cells
1. A cell can hold one of the following types of data:
a) Numeric value, Text, Formula, or Function
2. A worksheet can also hold these which reside on a worksheet layer:
a) Charts, Diagrams, Pictures, Buttons, and other Objects
3. The Home Tab and the Mini Toolbar are the locations of procedures for creating and formatting a worksheet
4. The Mini Toolbar [image: ]

C. [bookmark: _Toc85461319]There are several common features in the Excel worksheet
a) Certain Group Sections contain a “Dialog Box Launcher” which contains more options.
D. [bookmark: _Toc85461320]Formatting Cell Data in the Cell Format Dialog Box
[image: ]
E. [bookmark: _Toc85461321]Working with Cell Format Dialog Box
1. This dialog box corresponds with items on the ribbon
2. Put the cursor in the cell(s) to be modified
3. The formatting choices can be found three ways:
a) The first way is to find the process desired on the Home Ribbon
b) A second way is to go to any of the groups on the Home Ribbon. In the lower right-hand corner of that box, you will see a small arrow box. Select that arrow box with the mouse. 
(1) The “Format Cell” box appears with six choices.
(a) Numbers; Alignment; Font; Borders; Fill and Protection
(i) Select use of the numbers in the cell 
(ii) Example are given how the data will look
(iii) **Numeric Digits entered for any math calculations are formatted as number related attributes. Numeric Digits entered for parts of an address, SS#, Zip codes or parts numbers are formatted as text or specific attribute format
(b) In the Alignment section you select 
(i) Horizontal and Vertical characteristics
(ii) The most common aspect chosen in this section is the text control, and “wrap text” to contain all data placed in that cell in a cell size you create. 
(c) Orientation allows you to display data on an angle. 
(i) To do this, place the cursor on the red dot of the compass. 
(ii) Hold down on the left mouse button and slide the cursor up or down depending on the direction you want to place the data. 
(iii) You can also set the angle by number you place in the degree box.
(d) In the Font area, you select from a variety of fonts, font styles, and size of letters. 
(e) In the “Border” section you may select several styles of borders, or various presets of borders
(2) The Fill section, provides you with the ability to fill cells with assorted colors and pattern colors and styles
(3) The Protection section permits you to lock others out from changing the cells and formulas.
c) A third way to access the “Format Cell Box” is by placing the mouse in the cell to change→ selecting right mouse button→ select “Format Cells.”
4. Select the type of formatting you want to do.
a) The characteristics of the cells may be changed. Select the desired characteristics of that type of data for that cell.
b) Any data entered with at least one letter is automatically formatted text.
c) To format manually numeric data entered as text. Select right button on mouse.→ Select the Format Cells button.→ Select Text.
d) Working with Text
(1) Text includes letters and numbers.
(2) Excel stores all types of data. Text is not just the alphabet data, but also a combination of letters and numeral characters or just numerals for zip codes, numbers in addresses, and social security numbers. 
(3) Any combination of letters and numbers not used for mathematical computation is text. 
(4) It is best to keep numbers for any computation as numbers.
e) Working with Dates
(1) Entering Dates
(a) Enter dates using dashes, or forward slashes between month, day, and year.→ Place the cursor in a date cell and select right button and format cells.→ Go to the number tab and go down to dates. → Select the choice desired in the center set of choices for dates. 
(2) Various options display dates and times.  The “long date” includes the day, and date. A short date would just give the month number/day number/year’s last two digits. Time is expressed as hour: minute: second followed by AM or PM
(a) To enter a date or time, place the cursor in the desired cell. → Type in date or time → Press enter when done. 
(b)  To format your data to the desired style: 
(i) Put the cursor in the cell desired and type date numbers. → Go to the ribbon Number section, select long or short date button. 
(ii) A second way with a more exact list
(a) Select the right button of the mouse. → Select the Format cells item. → Date will be highlighted in the category or highlight it. 
(b) Display Options are to the right. 
(c) The default is for the United States but if you select the dropdown box, you will see other countries listed and they will show you the equivalents for that country. 
(3) Two options are available to format time found in the Format Cells box. You can choose the Time category and there will be choices to select, or you may pick some items in the custom category. → unless specified Excel assumes AM
f) Working with Numbers
(1) Entering Numbers
(a) To enter a number, simply move the cursor to the desired cell and enter the numbers. → Press enter when done→ To change the formats of numbers place the cursor in the cell and select right button on the mouse and select “format cell.” → Go to the number tab and choose the appropriate number format you desire to use. → then select ok when done.
(2) To cancel your entry at any time press Esc key
(3) Numbers can be entered in many formats including currency and percent
(4) You can manipulate the numbers no matter how they are formatted using various formulas
(a) To enter a decimal number, enter numbers separated by a period as a decimal point
(i) For example, if you enter the fraction ¾, Excel will interpret the fraction as a date March 4th.
(b) To enter a negative number, enter a minus sign in front of the number.
g) Working with Time
(1) Entering Time
(a) Place the cursor in the cell desired and type in the time AM or PM → Show the place on the ribbon where they may select different formats for showing time → Show the location in the format cells using the right button of the mouse review the manner.
h) Working with Special Information
(1) Deals with the layout of zip codes, phone numbers and social security numbers.
i) Working with Custom cell information
(1) A listing of various layouts that deal with number format codes
II. [bookmark: _Toc85461322]Worksheet Layout Formatting
A. [bookmark: _Toc85461323]Working with Rows and Columns
1. Naming Cells, Rows and Columns
a) Select cell, row, or column→ Select Formula tab→ Go to “Defined Name”→ Enter the name in the dialog box → Select OK
2. Changing Rows, Columns
a) Changing Row Height
(1) Move cursor to row header to the left of the row to be adjusted →Position cursor on bottom border of the line of that row → when cursor changes, hold down left button of mouse and drag down or up → Release button of mouse when finished.
b) Changing Column Width
(1) Place cursor on the right side of the header of the column to be adjusted. → at the change of the cursor shape, hold down on left button of mouse and slide the cursor to desired width → Release mouse
3. Inserting New Row and Column
a) Inserting New Row
(1) Place cursor in the row header after where you want to insert new → Use the Home ribbon and select Insert in the cells group → Alternative is to use the right mouse button and select Insert
b) Inserting New Column
(1) Place cursor in the column after where you want to insert → Insert the Home ribbon and select Insert in the cells group → Alternative is to use the right mouse button and select Insert
4. Deleting Row and Column
a) Deleting Row
(1) Place Cursor in row to be deleted→ In the Cells group on the Home ribbon select delete → an alternative is to use right mouse button
b) Deleting Column
(1) Place cursor on column header of column to be deleted→ Go to cells on the home tab and select delete →An alternative is to use right mouse button.
5. Moving Row and Column
a) Put cursor on row or column to be moved → select the clipboard section of the Home Ribbon → Place cursor on row or column where you want to move row or column → Select paste in the clipboard section of the Home Ribbon → Old data will be replaced with new.
6. Copying a Row or Column
a) Place cursor in the row or column that is to be copied → Go to the clipboard section on the Home Ribbon→ Select copy → Place cursor in destination row or column → Select paste
7. Inserting Cells
a) Select the location where you want to insert a cell → on the cell section of the home tab, click the arrow on the insert button, and select insert cells→ a dialog box will come up and select which way for the existing cells to move.


8. Deleting cells
a) Place the mouse on the cell you want to remove → Go to the cells section on the home tab and click on the arrow next to the delete button → A dialog box will appear asking which way you want the existing data to go.
9. Placing a column(s) between two columns
a) Select a whole column or columns to be moved→ place cursor to the line between the heading and the data so that it turns into the 4 prong cursor→ holding down the shift key on keyboard, click the columns you want to move and drag the column(s) to where you want them→ let go of the mouse→ column(s) should drop in new location
B. [bookmark: _Toc85461324]Placing Borders and Lines Around Cells
1. Highlight cell or cells to surround by borders or lines→ Home Tab→ Font→ Borders drop-down list→ select specific attribute
(1) [image: ]
C. [bookmark: _Toc85461325]Freezing and Unfreezing Rows and Columns
1. Freezing them
a) Column headers and row headers can be frozen to their locations
b) To freeze them place the cursor on the line beneath the rows you want to stay in position → Select the view ribbon tab and click on the freeze top row button in the windows section or the beginning of the next column line
2. To freeze more than one row or column, place the cursor on the top line of the row or to the right of the column and then select freeze → to unfreeze the column or row, click unfreeze panes button
D. [bookmark: _Toc85461326]Hiding and Un-hiding Rows and Columns 
1. Hide Row and Column
a) Select the row or column you desire to hide → Go to the cells section on Home Ribbon → Select Hide and unhide → Select hide.
2. Unhide Row or Column
a) Press down and hold the shift key the row or column headers you want to unhide→ Go to the cells section on Home Ribbon→ Select the format button and select hide and unhide → Select unhide for column or row

III. [bookmark: _Toc85461327]Cell Worksheet Formatting Features
A. [bookmark: _Toc85461328]Working with Cells
1. Selecting Cells
a) Cells by each other
(1) To select a cell, place the cursor in the cell and see the big white cross. → Select the cell and hold down mouse button over the cells you require →When the last cell is selected let go of the mouse
b) Cells not next to each other
(1) Select the first area required →Hold down the control button and select the other cells→ when the last cell is selected-let go of the mouse and control button.
2. Selecting the whole spreadsheet
a) Click on the square at the top left corner of the spreadsheet grid → Select the diagonal arrow in it pointing to the grid →This will select everything in the grid.
3. Selecting a row or column
a) Select the arrow on the number to the left and column letter across the top.
4. Selecting several rows and columns next to each other
a) Click and drag the mouse over the rows, holding down on the left button of the mouse and above the column letters across the top.
5. Selecting rows and columns not next to each other
a) Select the first row, then click on the control key and select the other rows desire and columns across the top.
B. [bookmark: _Toc85461329]Editing Cells
1. Once data is entered into cells, data may be edited one cell at a time and editing may be done in the cell itself or it may be done in the formula bar.
a) Place the mouse in the desired cell and use the backspace key to delete the existing characters and then type in the desired information into the cells or enter the formula desired → Press enter when finished.
2. When using the formula to edit a cell, click on the check mark to the left of the formula bar.
3. To edit the data in the active cell,
a) Place the mouse to the desired cell→ Press F2 to open cell → Move cursor to the point within the cell where you want to make an edit→ Use the backspace key and delete key to delete existing characters and then type in the information into the cell→ Press Enter.
4. To edit a cell when using the formula bar
a) Move the cell in question→ Position the mouse in the formula bar where you want to begin editing. →Position the mouse at the point where you need to edit.→ Make the necessary changes and press enter or click the check mark icon next to the formula bar.
C. [bookmark: _Toc85461330]Deleting Data
1. Delete data by pressing delete key one letter or number at a time.
2. Delete data by pressing backspace.
3. Delete data by selecting right button and click on delete.
4. Delete data by selecting Delete Contents when right button of mouse is clicked in appropriate cell.
5. Deleting data is different from cutting data.
a) Cutting data 
(1) Removes information from the cell then pasting to another cell
(2) Allows the data to be copied to the clipboard and then pasted to another location.
b) Deleting data completely removes data from spreadsheet.
c) To remove data from a row, next to each other of more than one cell at a time, press, hold the shift key, drag from the start point to the end, and select delete.→ the surrounding cells will move up or down.
D. [bookmark: _Toc85461331]Finding and Replacing Data
1. Finding
a) Go to home ribbon and then to the extremely far right-hand side in the editing section→ Select “find and select” and pick “Find or Replace” from the pull-down menu→
b) In the dialogue box, enter what you are looking for in the “Find What box”→ “Find All, or “Find Next”→ Select “Close” when done.
2. Replacing
a) Enter the information to be replaced in the box → Select next → Select replace again until finished → to replace all items click the “Replace All” button.
E. [bookmark: _Toc85461332]To Move Cells
1. Place cursor in the cell to be moved →Select cut →Enter cursor in the relocation cell→ Select paste
F. [bookmark: _Toc85461333]To Copy Cells
1. Place cursor in the cell to copy→ Select copy→ Enter cursor in the relocation cell→ Select paste
G. [bookmark: _Toc85461334]Paste Options 
1. PASTE
a) [image: ]Paste: standard paste option with original content with its original formatting preserving any formula from the original cell
b) [image: ]Formulas: pastes only the data and formula from the original cell, not the formatting. Paste data inherits the formatting of the target cell
c) [image: ]Formulas & Number formatting:  pastes the data and formulas. All numbers copied retain their original number formatting, but no other formatting is retained
d) [image: ]Keep source formatting  pastes the contents and the formatting of the original cells
e) [image: ]No borders:  pastes all the data formulas and formatting from the original cells except any borders from those cells
f) [image: ]Keep source column widths:  pastes data, formulas, and formatting from the original cell; also changes the column width of the new cell to match the width of the original
g) [image: ]Transpose:  change the orientation of the pasted entries. For example, rows to columns
2. PASTE VALUES
a) [image: ]Values:  pastes only the calculated results of a formula, not the formula itself
b) [image: ]Value and Number Formatting:  pastes the calculated results of a formula along with all the formatting assigned to the original labels, values, and formulas in the source selection
c) [image: ]Value & Source Formatting:  pastes the calculated result of a formula along with all formatting assigned to the source cell range
3. OTHER PASTE OPTIONS
a) [image: ]Formatting:  pastes only the formatting not the original cells data   Use to apply one cells formatting to another
b) [image: ]Paste link:  when copying a formula, this retains the reference to the original source cells
c) [image: ]Picture:  pasts only pictures found in the original selection
d) [image: ]Linked picture:  pastes a link to the pictures in the original selection
4. Advanced Paste Special
(1) [image: ]
b) Paste values:  use this choice to paste the result of a formula rather than the whole formula
c) Paste formats:  use this choice when you want to build a structure on a worksheet that exists elsewhere
d) Paste cell values without formulas
(1) Select and copy source content→ select the cell→ Home tab→ Clipboard group→ display Paste list→ Paste Options→ click the Values button


e) To Transpose rows and columns
(1) Select and copy the source data→ upper-left cell of the range to copy transposed values→ select cell→ on Home tab→ Clipboard group→ display Paste list→ in the Paste section→ click the Transpose button
IV. [bookmark: _Toc85461335]Changing the Appearance of a Workbook/Worksheet Content
A. [bookmark: _Toc85461336]Use Predefined Themes 
a) [image: ]
B. [bookmark: _Toc85461337]Applying a Theme 
1. Page Layout→ go to Themes group→ click the Themes button→ select the theme to be applied from the gallery
2. Using one of these predefined themes, the worksheet is formatted by a combination of colors, fonts, and effects.
3. Elements of one theme pattern and some of another theme, may be mixed and matched  
C. [bookmark: _Toc85461338]Cell Style Formats 
1. Cell styles are created to tie formats to the workbook theme color and some with implied meanings.
2. Standardize formatting throughout the workbook by applying cell styles to content
3. Place cursor in the cell for formatting→ select cell styles→ select choice of color

[image: ]                     
V. [bookmark: _Toc85461339]Conditional Formatting 
A. [bookmark: _Toc85461340]Highlight Cells
1. Cells that contain data within a specific range of numbers, specific text, or duplicate values 
a) [image: ]
B. [bookmark: _Toc85461341]Top/Bottom
1. Cells that contain the highest or lowest values
a) [image: ]   
C. [bookmark: _Toc85461342]Data Bars 
1. Portion of each cell corresponding to the relationship of the cells data to the rest of the data in a range
a) [image: ]
D. [bookmark: _Toc85461343]Color scale 
1. Cell with a color point from a two color or three-color gradient corresponding to the relationship of the cells data to the rest of the data in the range
a) [image: ]
E. [bookmark: _Toc85461344]Icon sets 
1. Specific icons that correspond to the relationship of the cells data to the rest of the data in the range
a) [image: ]

F. Selection Choice Dialog 
1. Used to assist in formatting aspects of conditional formatting
2. [image: ]

VI. [bookmark: _Toc85461345]Using and Creating Templates 
   [image: ]  
A. [bookmark: _Toc85461346]Template is a model that represents something else.
1. It is a special workbook used as a basis to create other workbooks
2. It is an example to show what Excel can do.
3. They are functional, but using them causes restriction to the parameters of the template  
B. [bookmark: _Toc85461347]Selecting Templates
1. To find them select File→ select the New Tab→ pictures are given as well as a categorical listing of various templates
C. [bookmark: _Toc85461348]To create a workbook from a template model
1. Select template to use→ click Create→ workbook is created→ use Save As to create a name and location for the template workbook.
D. [bookmark: _Toc85461349]Creating Custom Templates
1. Create workbook/sheet with all formulas and functions and formatting installed→ select Save As→ Create Name and enter it in the document directory dialog box→ select Save As Type→ select Excel Template→ save template workbook in the Templates folder
E. [bookmark: _Toc85461350]Using Created Template Workbooks
1. Once a blank template workbook is created and saved, it can be used over and over, by changing the name with the Save As option. Original will be saved and closed. New workbook will be saved in Template file folder.
VII. [bookmark: _Toc85461351]Searching for Data in a Workbook
1. [bookmark: _Toc82508062][bookmark: _Toc82517932][bookmark: _Toc82518948][bookmark: _Toc85461352][image: ]
B. [bookmark: _Toc85461353]Find and Replace Dialog Box
1. Specific values, formulas, comments, and formatting anywhere in a workbook or worksheet by using Find and Replace
2. Home tab→ Editing group→ display Find and Select List→ click Find
3. Search for Text
a) Display the Find and Replace dialog box→ Find What field→ type information to be sought
b) Select Options→ click Expand
c) Select the three elements of criteria
(1) Within:  Sheet or Workbook
(2) Search:  Rows or Columns
(3) Look in:  Formulas, Values, or Comments
d) Search for Formatting
(1) Find and Replace Dialog Box→ click Format→ specify number, alignment, font, border, fill or protection formatting to be found→ ok→ Find Next
e) Select matching
(1) By case
(2) By matching entire cell contents
VIII. [bookmark: _Toc85461354]Navigating with the Go To dialog box and the Special Commands box

[image: ][image: ]
A. [bookmark: _Toc85461355]Opening the Go To Dialog box 
1. Home Ribbon→ Editing group→ Find and Select button→ select Go To
2. To move to a named cell, range, or workbook element
a) Formula Bar→ click Name box arrow→ select named element or
b) Open Go To dialog box→ click a named element in the Go To list→ click OK
3. To move to a location that has a specific property
a) Go To Special dialog box→ Select area→ click the property for search→ OK
4. These are used to locate a specific element or type of element
5. [bookmark: _Toc82518953]From the Go To dialog box, any named element may be found: Cell, Range, Table, chart.
6. [bookmark: _Toc82518954]From the Go To Special dialog box these can be found: comments, formulas, special elements, blank cells, objects, rows/column differences, special formula data




IX. [bookmark: _Toc85461356]Inserting Data into Cells

[image: ][image: ]   
A. [bookmark: _Toc85461357]Fills
1. Auto Fill Repeat data
a) Is a feature that allows you to fill a range of cells with data
b) Fills permit you to fill a block of cells with the same bit of information or with consecutive bits of data in a series.
c) Type the content in the first cell → Position cursor so it hovers over the bottom right of the cell, so it turns into a black cross → Click and drag horizontally or vertically to copy the content → when the smart tag appears, click the down arrow, and select copy cells from the series of options.
2. Auto Fill Series
a) Fills data to adjacent cell in series incrementing each cell by 1
(1) Type the content in the first cell and the second cell. → Position the cursor so it hovers over the bottom right of the first and second cell turning it into a small black plus symbol. → Click and drag horizontally or vertically the black cross over to the last cell desired.→ When you let go of the cursor the content is copied with an increment increase of 1 or the next logical item in sequence.
(2) This can also be used for days, months and dates
b) When you see the smart tag, click on it and select fill series
c) This set of steps may be used to copy formatting as well
3. Auto Fill Options Menu
a) To fill a simple numeric, day, or date series
(1) Upper left cell of range to fill→ enter first number, day, or date to create→ select cells that define the series→ drag fill handle down or to the right to create an increasing series
b) To fill a specific day or date series
(1) Fill the series→ click Auto Fill Options button→ click Fill Series→ on the Auto Fill Options menu→ click Fill Days, Fill Weekends, Fill Months, Fill Years
(2) For a numeric, day or date
(a) Enter number or beginning date in series→ select cell range to be filled→ Home tab→ Editing group→ Fill list→ click Series→ select options→ click OK
4. Flash Fill
a) Flash Fill permits dividing data in one cell or column into multiple cells or columns.
b) Select the column that contains data that you want separated → Create an empty column next to the column that you want separated → Type the result you want in the first cell (which is the part you want separated). → Type the result you want in the second cell. → Highlight the column where the results are found including the cells you want to fill to the end of the column and release the button. → This type of fill will only process one column at a time. → Once the area is selected, select the button called Flash Fill in the Data Ribbon Tab. → Cells will be filled in after pushing the button. → Flash fill can also record parts of a cell that you desire by placing the desired results in a couple of cells. → Highlight the column of desired results and the desired cells you want to fill.
c) Alternative Method for Flash Fill
(1) Type in the first two entries desired.→ Highlight the column to be filled.→ Home Tab→ Editing Group → Fill Command →Flash Fill.

X. [bookmark: _Toc85461358]Printing a Spreadsheet 
A. [bookmark: _Toc85461359]Selecting Print Area
1. Highlight the entire area that you want printed by placing the cursor at the first cell at the top left
2. Press and hold the shift key and click the mouse in the last cell in the range desired
3. Go to the “print area” in the “page setup” on the page layout ribbon tab section and select “Set Print Area”
4. Select the file tab at the top of the spreadsheet
5. Go to the backstage page and pick the “Print Button in the green area
B. [bookmark: _Toc85461360]Creating Print Page
1. At the bottom of the print options there is a line called the Page Setup. Select it to open the dialog box
2. At the dialog box select the footer and header, enter the header information 
a) To enter header information, select the custom header button and footer info if desired
b) At the top of the header are instructions for working with the distinct characteristics of data
c) A box of 3 sections will be visible, one for the left side of page, then center of page and then right side of the page
d) In the center there are icons that represent options that may be entered 


                               [image: ]
3. Determining Page Settings
a) Orientation choice is portrait or landscape
b) Select the scaling desired to show data on the page
c) Select Margins Tab and determine how you want the document to be  centered for printing
d) Above the page setup is a series of dropdown boxes to set print criteria
(1) Select the printer to use
(2) Select if you want one side print or two-sided printing
(3) Select the collation format to be followed
(a) 111 222 333 or 123 123 123
(4) Select the size of paper.

XI. [bookmark: _Toc85461361]Introduction to Formulas and Functions
A. [bookmark: _Toc85461362]Ranges of Cells  (What do you think a range does?)
1. A range is a designated group of cells in a worksheet
2. A range will appear highlighted and surrounded by a dark border
3. Characteristics about ranges
4. They serve as an argument for a function.
5. They are the data when making charts and graphs.
6. They are the labeled bookmarks for specific data.
7. Selecting range data from multiple worksheets in an Excel workbook is a 3D range.
[bookmark: _Toc82517944][bookmark: _Toc82518960][bookmark: _Toc85461363][image: ]

[bookmark: _Toc82517945][bookmark: _Toc82518961][bookmark: _Toc85461364][image: ]





B. [bookmark: _Toc85461365]Types of Ranges
1. Contiguous (Cells adjacent to each other)
2. Noncontiguous (Two or more separate blocks of cells)
C. Ranges in an Excel Worksheet (Go to Companies in Excel Workbook and mark out range types)
1. To show a contiguous range of cells
a) Open Excel II Test Workbook→ Select Companies Tab→ Select two columns adjacent to each other to show a contiguous range of data from the worksheet
2. To show a noncontiguous range of cells
a) Select columns A and B→ hold down on CTRL key→ select column D
3. Transposing Rows and to Columns in a Worksheet(Show and have class transpose column headers)
a) Highlight column of data to be transposed→ RMB→ select Copy→ place the arrow on the first-row number so it highlights the entire row→ select RMB→ Select the Transpose paste button→ column titles will fill the cells of the first row for each column





XII. [bookmark: _Toc85461366]Subtotaling

[bookmark: _Toc85461367]                                    [image: ]

A. [bookmark: _Toc85461368]How to subtotal a range of data in a worksheet
1. [bookmark: _Toc85461369]  A subtotal calculates a summary such as Sum or Average by using the subtotal function
a) [bookmark: _Toc85461370]More than one type of summary function can be displayed for each column.
b) [bookmark: _Toc85461371]Grand totals are derived from detail data, not from the values in the subtotals.
c) [bookmark: _Toc85461372]Process
(1) [bookmark: _Toc85461373]Make sure that each column in a range of data for which you want to calculate subtotals has a label in the first row.
(2) [bookmark: _Toc85461374]Make sure that each column contains similar facts 
(3) [bookmark: _Toc85461375]Make sure that there are no blank cells in rows and columns
(4) [bookmark: _Toc85461376]Sort Data ascending
(5) [bookmark: _Toc85461377]When using the subtotal feature, you choose items to be subtotaled from left to right in the table and they will be listed in the dialog box in that order
(6) [bookmark: _Toc85461378]Answer the three questions from dropdown boxes for each desired subtotal.
(a) “At each change in”
(b) “Use function”
(c) “Add subtotal to”
(7) [bookmark: _Toc85461379]Check or uncheck the checkboxes at the bottom
(a) “Replace current subtotals”
(b)  “Page break between groups”
(c)  “Summary below data”
(8) [bookmark: _Toc85461380]Pressing “Remove All” removes all subtotals and restores worksheet to initial state.

(9) [bookmark: _Toc85461381]Place the cursor in A2→ select Data Tab→ go to the Outline group→ select Subtotal icon→ subtotal dialog box appears→ in “At each change in”, select year→ in “Use Function” field, select Sum→ In the “Add Subtotal to” field choose Number→ uncheck “Replace current subtotals→ select “Summary below data→ select OK→ grouped categories are subtotaled→ select Subtotal again→ in “At each change in” select Type→ in “ Use function+ select Sum→ In the “Add subtotal to” Number→ uncheck “Replace current subtotals”→ select OK→ the number of each type of returns and grand total of returns will be displayed
2. [bookmark: _Toc85461382]  How to copy subtotal values from subtotaling to another location
a) [bookmark: _Toc85461383]Select the subtotal that you want to copy→ place cursor in top left cell→ Select Ctrl+A→ cells will be highlighted→ Home tab→ Editing group to right→ click Find & Select→ Go to Special→ select Visible Cells Only→ Ctrl+C to copy selected→ go to destination page→ press Ctrl+V

XIII. [bookmark: _Toc85461416][bookmark: _Toc85461384]Consolidating Data Worksheets
A. [bookmark: _Toc82519004][bookmark: _Toc85461417]A worksheet template created for distribution for various departments. Once the department workers fill in the worksheets, and returned the worksheets to the source person, the worksheets combined, form a single worksheet for tabulation. This process is called consolidation.
B. [bookmark: _Toc85461418]Two methods to consolidate worksheets
1. Consolidate by position
a) Must maintain identical layout (Enter Consolidation Worksheet)
b) Create a separate consolidation worksheet with same layout
c) Open consolidation totals worksheet→ select the cell of the destination range to be positioned→ select Data Tab→ Data Tools Group→ select Consolidate→ Consolidate dialog box appears.
d) In the Consolidate dialog box go to Function dropdown list→ select the Sum operation to use during the consolidation.
e) In the Consolidate dialog box go to the Reference text box→ enter reference for one of the source ranges→ then do one of the following steps:
(1) Type the range coordinates by hand, 
(a) If the range desired is in another workbook include workbook name in square brackets
(2) If the sheet is open, select it by clicking it or clicking it in the View or Switch Windows menu→ use mouse to highlight the range
(3) If the workbook is not open, click browse→ select file in Browser dialog box→ click OK→ Excel adds the workbook→ fill in sheet name and range coordinates
f) Click Add→ Excel adds the range to the All-References box
g) Repeat the above two steps until all source ranges are listed→ click OK→ Excel gathers the data and consolidates it and then adds it to the destination range totals
h) If you choose to add links to source data, these three things happen:
(1) Link formulas are added to destination range for each cell in the source ranges
(2) Consolidates the data by the operation selected that total the results of the link formulas
(3) Outlines the consolidation worksheet
2. Consolidate by category
a) Consolidate by category is for consolidating data when the same layout is not used. Excel examines each of the source ranges and consolidates data that uses the same row or column labels.

XIV. Formulas and Functions
A. [bookmark: _Toc85461385]Introduction to formulas and functions
1. Formulas and functions are questions that you are asking the computer program to answer in a specific cell location and manner in a worksheet.
2. Microsoft created guidelines in which formulas and functions are entered into cells.
a) The description of the question and its order of entry is called the “Syntax” of the formula or function.
b) To arrive at the desired answer, the syntax follows the guidelines established, and the order affects the results of the formula.
B. What is the difference between a formula and a function? 
1. Difference between a formula and a Function
a) A formula is a self-defined set of instructions for performing a calculation producing a particular result
b) A function is a pre-defined formula or formulas combined in a unique way to bring about a particular calculation as created by Microsoft.
2. What are some of the things that formulas and functions can be used? 
3. Formulas and functions are useful in performing
a) Number crunching
b) Data analysis
c) Forecasting productions in business
d) Visualizing information through charts and graphs
4. Formulas
a) Basic key factor of formulas
(1) When data in the computations change, the formulas automatically change the answer in accord with the data
b) Formula characteristics
(1) What makes a formula a formula?
(a) A formula always starts with an = Sign
(i) The =Sign goes in the cell where you want the formulas answer
(ii) The =Sign states that the content in the cell is associated with a formula
(iii) The =Sign shows the answer rather than the formula
(b) A formula may or may not contain functions
(i) A function is a pre-defined expression to perform a calculation
(ii) There are over 300 built in excel functions
(c) A formula may or may not contain a parenthesis
(i) The use of the parenthesis impacts the result of the formula
(ii) The parenthesis changes the order evaluation
(iii) The first calculation done in the formula is the calculation in a parenthesis
(iv) A formula may contain multiple sets of parentheses
(v) When a parenthesis is opened in a formula, it must be closed at the end.
(d) A formula contains operators
(i) Using operators in formulas do different calculations
(a) Arithmetic: basic math operations
(i) Percentage %
(ii) Addition +
(iii) Subtraction –
(iv) Division /
(v) Multiplication *
(vi) Exponent ^
(b) Comparison: compares two values with specific operators producing a logical value
(i) Equal to =
(ii) Greater than >
(iii) Less than <
(iv) Equal to or greater than =>
(v) Equal to or less than =<
(vi) Not equal to <>
(c) Reference: combines ranges of cells for calculations
(i) A Colon
(ii) A Comma
(iii) A Space
(e) A formula contains cell references
(i) References designate a location of a cell where a column and a row 
(f) A formula may or may not contain constants
(i) A Constant is a number or test value entered directly into a formula
(ii) A Constant is a value that is not calculated or changed
(2) Operator Precedence
(a) Operator Precedence is a set order in which calculations occur established by Microsoft, which is unchangeable and must be entered in the set order for any calculation to take place
(i) Range
(ii) Intersection
(iii) Union
(iv) Negation
(v) Percentage
(vi) Exponents
(vii) Multiply and divide
(viii) Add and subtract
5. Diverse ways to enter formulas
(1) Enter it into the cell directly
(2) Enter it into the formula bar
(3) Enter it in the cell using the insert function button on the formula tab 
(4) Is it possible to enter the same formula different ways? (Use Formulas Worksheet in workbook) 
(a) Ref A2 is 1 B2 is 2, C2 =3+1 answer is 3
(b) Ref A3 is 1, B3 is 2, C3 =A3+B3 answer is 3
(c) Ref A4 is 1, B4 is 2, C4 =sum(A4+B4) answer is 3
6. The Power of the Parenthesis 
(1) The parenthesis in Excel formulas 
(a) The use of the parenthesis does affect the result of the formula.
(b) The parenthesis changes the order of evaluation.
(c)   The first calculation done in the formula is the calculation in a parenthesis.
(d) A formula may contain multiple sets of parentheses
(e) Remember to double check your use of parenthesis
7. Enter a blank page in a workbook, go to Formulas 2 tab→ enter the formulas in Column A in each of the cells in that column→ to double check the answers → place pointer tip in the cell where the formula is located→ go to the Formula Tab→ select Evaluate Formula→ follow through each of the explanation steps of the formula
8. This exercise is designed to show the impact of the Parentheses
a) =3^(15/3)*2-5
b) =3^((15/5)*2-5)
c) =3^(15/(5*2-5))
d) =7+5*20+25/5     
XV. [bookmark: _Toc85461386]Internet Locations for help with Formulas and Functions
A. [bookmark: _Toc85461387]Microsoft Support Sites
[bookmark: _Toc85461388]1.	Alphabetical
a) [bookmark: _Toc82518968][bookmark: _Toc85461389]https://support.microsoft.com/en-us/office/excel-functions-alphabetical-b3944572-255d-4efb-bb96-c6d90033e188    
2. [bookmark: _Toc85461390]Categorical
a) [bookmark: _Toc82518970][bookmark: _Toc85461391]https://support.microsoft.com/en-us/office/excel-functions-by-category-5f91f4e9-7b42-46d2-9bd1-63f26a86c0eb
b) [bookmark: _Toc82518971][bookmark: _Toc85461392]ExcelJet: https://exceljet.net/
c) [bookmark: _Toc82518972][bookmark: _Toc85461393]ExcelFunctions.net: https://www.excelfunctions.net/index.html
d) [bookmark: _Toc82518973][bookmark: _Toc85461394]Excel Easy: https://www.excel-easy.com/
e) [bookmark: _Toc82518974][bookmark: _Toc85461395]keynote supports excel functions: https://www.keynotesupport.com/excel-functions/if-function.shtml
f) [bookmark: _Toc82518975][bookmark: _Toc85461396]Digital.com: https://digital.com/excel-tutorials/

XVI. [bookmark: _Toc85461397]Error codes  (Why are error codes beneficial to Excel?)
A. [bookmark: _Toc85461398]Error codes 
1. [bookmark: _Toc85461399]are enumerated messages that corresponds to faults, such as those in faulty hardware, software, or incorrect user input
B. [bookmark: _Toc85461400]Understanding Error Codes
a) If you try to enter an incorrect formula, Excel will not let you do anything else until it is either fixed or cancelled. 
b) When you enter or edit a formula, one of the formulas input values, Excel might show an error value as the formula result.
c) Excel has Eight different error codes.
(1) #####: width of column is short
(2) #VALUE!: Wrong type of argument.
(3) #DIV/O:  cells formula is trying to divide by 0 or an empty cell(5)
(4) #N/A  means not available: means that the formula could not return a legitimate result. Excel cannot find a lookup value within a specified lookup table. It is likely that: 
(a) The lookup value does not exist within the lookup table. 
(b) The data type of the lookup value is not consistent with the entry in the lookup table. 
(c) Your lookup value does not match the value in the lookup table. Check for leading and trailing spaces.
(5) #NAME? appears when Excel does not recognize a name you used in a formula or when it interprets text within the formula as an undefined name. 
(a) A function or name is not recognized. 
(i) Usually the result of a typo
(6) #REF! a formula contains an invalid cell reference. 
(a) Result of an invalid reference in your formula. This occurs usually when you delete the physical reference. The reference in the formula points to nothing.
(7) #NUM! means there is a problem with a number in a formula or there is an invalid argument in a function.
(8) #NULL! used specifically when you use the intersection operation on two ranges that have no cells in common and occurs when you specify an intersecting range, which in fact does not intersect. 
d) Process of Troubleshooting Formulas
(1) Through Auditing the Worksheet
(2) Through Reading the Error Codes
(3) Through Fixing Errors
e) Auditing and Troubleshooting Error Codes
(1) Trace Precedents 
(a) Precedents are all cells that are referred to by a formula [e.g., =AVERAGE (C6:C10) where C6:C10 are the cells referenced in the formula. For example, there is a #DIV/0! error, in a formula. By using the Trace Precedence tool, we can see which cells are referred to by the formula. 
(b) To trace the precedents of a formula: 
(i) Select the cell that contains the formula you wish to audit. → In the Ribbon, click the Formulas tab. → In the formula auditing group, click Trace Precedents. → Tracer arrow will highlight the cells referenced and point to the formula → To remove the tracer arrows from the spreadsheet, click remove arrows in the formula.

(2) Trace dependents
(a) Dependents contain formulas that refer to other cells. → Formulas using this tool can see what formulas are referred to in other cells. 
(b) To trace dependents, select the cells that you wish to audit.→ In the Ribbon, click the formulas tab. → Click Trace Dependents. → A trace arrow will point to the formulas referencing the selected cells. → To remove the tracer arrows from your spreadsheet, click remove arrows in the formula auditing tools.
(3) To show formulas
(a) Results of formulas will show in the cells of our spreadsheet and the formula itself within the formula bar.
(b) By using the show formulas tool, you can display all formulas within the spreadsheet, so they are visible within the cells.
(i) In the ribbon click formulas tab. → Go to formula auditing group and click show formulas. → All formulas within the spreadsheet will be shown. → To reverse click show formulas and select hide formulas.
(4) To do error checking   
(a) Error checking tools acts like the spell check. → Error will be highlighted, and the tool will provide information on that error. → On the formulas tab and formula-auditing group, select error check. Error checking will go through the spreadsheet and check the errors like Word spell check.
(b) To trace errors, tracker arrows will show the relationship between cells. The trace error tool will only work if the selected cell has an error value. By using the trace errors, we see what cells are referenced in the formula.
(c) Select a cell on the spreadsheet that contains error value. → Click formulas tab→ Click drop down arrow in the formula auditing group to check error. → Click trace error in the drop-down menu. → An arrow will highlight the cell referenced and point to the formula. → To remove the tracer click remove arrows in the auditing tools group.
(5) To track changes
(a) Click review tab → Select track changes in the changes group. → Click highlight changes in the drop-down menu. → The highlight changes window will appear. → Click checkbox next to Track Changes while editing. → The options under highlight which changes, will become active and select all that applies. → Make sure the highlight changes on screen checkbox have been checked. → click OK.
(6) Reviewing tracked changes
(a) Excel will track the changes that occur once it has been enabled.
(b) Edited cells will be marked by a blue border with a blue triangle in the upper left corner.
(c) Hovering over a cell that has been marked will have a pop up with more info displayed.
(7) Fixing Errors (Slide 11)
(a) Evaluate the Formula
(b) Breakup Long or Complex Formulas
(c) Recalculate the Formula
(d) Check the Order of Precedence
(e) Watch for Blank Cells and Values

XVII. [bookmark: _Toc85461401]Elements of Functions
A. [bookmark: _Toc85461402]A function is like a Tylenol capsule
1. It is made of an outer shell
2. Inside are the many ingredients in a form of formulas to do special things
3. If a capsule is pulled apart, beads fall out, and will not fit back together the same way if it can be done
4. Microsoft has a patent on how functions are compacted together to provide the answers to questions using pre-designed formulas.
B. [bookmark: _Toc85461403]A Function Layout
[bookmark: _Toc82517966][bookmark: _Toc82518982][bookmark: _Toc85461404]             [image: ]
C. [bookmark: _Toc85461405]Characteristics
1. Excel starts the function with the = Sign to tell Excel that a question is being asked through a function.
2. The Name of the function being used is SUMPRODUCT
3. The first Open paren. sets apart the arguments that will follow
4. The first argument or first set of reference range is the A2:A6
5. The comma separates the arguments
6. The second reference range is then listed B2:B6
7. The function of SUMPRODUCT is closed with a closing paren.
D. [bookmark: _Toc85461406]Built in Functions
1. Function Structure
a) All have FUNCTION (argument1, argument2…)
b) Arguments are all the items within the parentheses and separated by commas.
c) Functions are preset formulas that Excel makes to carry out a specific calculation, format in the cell in which it is located.
d) Worksheet functions allow us to pass instruction to Excel on how to evaluate terms.
e) Functions make simple cumbersome formulas easier to use.
f) Functions enable you to include complex expressions that would be difficult to construct using simple math.
g) Functions enable you to include data in the app that could not be accessed.


XVIII. [bookmark: _Toc85461407]Function Categories
[bookmark: _Toc82517970][bookmark: _Toc82518986][bookmark: _Toc85461408]   [image: ]

XIX. [bookmark: _Toc85461409]Auto Sum Functions
A. [bookmark: _Toc85461410]There are five AutoSum Functions
1. [bookmark: _Toc85461411]Formulas commonly used - found in the second group, on the Formulas ribbon tab or are in the Editing group on the Home ribbon tab. 
B. [bookmark: _Toc85461412]Use
1. Select the cell below the column of numbers you want to place answer of function→ select the desired function→ select the cells to have function acted on→ press enter. (Go to blank worksheet and demonstrate
C. [bookmark: _Toc82517981][bookmark: _Toc82518997][bookmark: _Toc82517982][bookmark: _Toc82518998][bookmark: _Toc82517983][bookmark: _Toc82518999][bookmark: _Toc82519000][bookmark: _Toc85461413]Auto Functions
[bookmark: _Toc82517985][bookmark: _Toc82519001][bookmark: _Toc85461414][image: ]
1. Sum
a) This function gives the total of a range of cells, entire column
b) The SUM function can be used to total a contiguous or noncontiguous cells
2. Average
a) This function calculates the arithmetic mean of a group of numbers, ignoring logical values, empty cells, and text cells
3. Count
a) This function counts the number of cells that contain numbers
4. Max
a) This function displays the maximum value in a group of cells
5. Min
a) This function displays the minimum value in a group of cells
D. [bookmark: _Toc82519002][bookmark: _Toc85461415]Recently Used
1. The Recently used group of functions is a listing of functions used in a short previous time

XX. [bookmark: _Toc85461419]The Function Wizard
A. Open the Insert Function dialog box. 
1. Parts of the Function Box. 
2. [image: ]
a) Type a brief description of what you want to do→ Click GO.
b) If you know the name of the function category, select the group from the category dropdown box.
c) There is a brief description of the selected functions.
d) A link takes you to Excel’s comprehensive list of functions help menu for more details on the selected function as well as examples.
3. Once you have found the function, select it, then click OK. 
4. To change data:
a) Data can be changed in the text box by:
(1) Clicking in the formula bar, in the main excel window, and changing the data
(2) Dragging over cells behind the function arguments dialog box
(3) Temporarily collapsing the Function Arguments dialog box by clicking on the collapse dialog icon. Large ranges can be selected without hindrance.
5. When you have finished filling in all the arguments required in your function, click on ok. 
a) You will be required to enter the arguments
b) Results are visible to the right of the box
c) Select OK

[bookmark: _Toc82519008][bookmark: _Toc85461421][image: ]
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